Falling back to Elasticsearch7 when search engine set to Opensearch
This article provides a solution for the issue when a Falling back to Elasticsearch7 error occurs when the search engine is set to OpenSearch in ÃÛ¶¹ÊÓƵ Commerce.
Affected versions
ÃÛ¶¹ÊÓƵ Commerce on cloud infrastructure 2.4.4 - 2.4.5
Issue
You set your search engine to OpenSearch, but see this type of error in the var/log/support_report.log
file:
[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []
Steps to reproduce:
- Verify that OpenSearch is installed by running this command:
curl 127.0.0.1:9200
If it indicates 1.2.4, then OpenSearch is already installed. - Go to Stores > Configuration > Catalog > Catalog Search.
- Check the search engine. It will show Elasticsearch7.
Cause
Even though your version does support OpenSearch, the application will only recognize/accept Elasticsearch7 as the search engine.
Starting in ÃÛ¶¹ÊÓƵ Commerce version 2.4.6, the application was updated to allow OpenSearch to be selected as the search engine.
If you go to Stores > Configuration > Catalog > Catalog Search in a non-cloud environment, you will be able to change this option as shown in the Solution below.
(Note: In a cloud environment, this field can’t be changed because the search engine is locked in the app/etc/env.php
file.)
Solution
Update the SEARCH_CONFIGURATION
variable in the .magento.env.yaml
file, and ensure that the search engine is set to elasticsearch7.
Related reading
Set up OpenSearch service in the Commerce on Cloud Infrastructure guide.