PayPal sandbox account not verified
This article explains why your PayPal sandbox account for Payment Services may not be verified, disabling you from completing sandbox onboarding.
Affected products and versions
- is now compatible with ÃÛ¶¹ÊÓƵ Commerce versions 2.4.0 to 2.4.4.
Issue
Our onboarding documentation instructs you to sign up for a PayPal account, log into the PayPal Developers account, and then create a sandbox account. If you select to create a new account during onboarding in the PayPal onboarding popup window, PayPal will not be able to verify your sandbox account and you will be unable to complete onboarding.
Steps to reproduce:
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You install Payment Services and configure your Commerce Services.
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You navigate to Payment Services in the Admin and start sandbox onboarding.
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In the PayPal onboarding popup that appears, you create a new Business account (instead of logging in with a previously-created PayPal sandbox account during onboarding.
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You successfully complete PayPal onboarding.
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You see a notification in the Admin that your sandbox payments are pending and that you must confirm your email address with PayPal to complete onboarding.
You did not receive a confirmation email because PayPal was unable to verify your email address.
Cause
PayPal will not be able to verify your sandbox account and you will not be able to finish sandbox onboarding (which means you cannot accept payments or test your sandbox mode) if you create your sandbox account before your PayPal account.
Solution
- Using a sandbox account created in the Portal.
- Click reset sandbox and restart your sandbox onboarding.
- Contact Support if you cannot alleviate your account issues so that you can resume onboarding and accept payments.